[GTER] FreeBSD 10 com OpenBGPD.

Marcelo Gondim gondim at bsdinfo.com.br
Thu Mar 27 09:38:48 BRT 2014


Em 27/03/14 08:21, Antonio Modesto Amaral Sousa escreveu:
>
>
> On Wed 26 Mar 2014 03:52:48 PM BRT, Marcelo Gondim wrote:
>> Em 26/03/14 08:49, Antonio Modesto Amaral Sousa escreveu:
>>> Estou tendo alguns problemas aqui com drivers em(4) quando uso
>>> vlan's, simplesmente não pinga nem trafega nada, além do status da
>>> interface ficar em "active" mesmo após o cabo ser removido. O
>>> problema só acontece com autoselect habilitado, fixei em 1000baseTX
>>> full-duplex e funcionou normalmente. O problema acontece tanto com o
>>> 9 quanto com o 10, em 32 e 64 bits (testei).
>> Antonio,
>>
>> Estranho esse seu caso porque meu ambiente é justamente esse:
>>
>> - LACP + VLANs ou seja eu tenho um link aggregation e em cima dele
>> tenho as vlans e as interfaces são todas em(4).
>>
>> Não tenho tido problemas com isso não. O problema que tenho é com um
>> Datacom relacionado à tabela de mac address... depois que uma das
>> operadoras que nos atende atualizou o Datacom deles, passei à ter que
>> setar o mac estaticamente das minhas interfaces na tabela arp e eles
>> ainda não resolveram isso. Com a outra operadora funciona normalmente.
>
> Fala Gondim,
>
> Conforme o Patrick falou , o problema acontece em alguns chipsets. Eu 
> estou tendo esse problema tanto naquela caixa que citei a algum tempo 
> atrás (Mikronoc 7500) e com o ServerU, basta fixar a velocidade da 
> interface que funciona perfeitamente. Um detalhe é que cheguei a usar 
> o Mikronoc por um tempo com o FreeBSD 8-STABLE e o problema realmente 
> não existia.
>
Pois é, eu li o que o Patrick colocou e acho que fui sortudo então na 
escolha do meu hardware. rsrsrs
Antonio, você já testou se o problema continua com um 10-STABLE nessas 
últimas revisions?

Grande abraço,

>>
>>>
>>> On Wed 26 Mar 2014 12:28:11 AM BRT, willian pires wrote:
>>>> Tudo ok, e com drivers intel atualizados :-)
>>>>
>>>>> Date: Tue, 25 Mar 2014 23:08:43 -0300
>>>>> From: gondim at bsdinfo.com.br
>>>>> To: gter at eng.registro.br
>>>>> Subject: Re: [GTER] FreeBSD 10 com OpenBGPD.
>>>>>
>>>>> Em 25/03/14 20:04, Jeferson Tadeu R. da Silva escreveu:
>>>>>> Todos,
>>>>>>
>>>>>>     Alguém por aqui que use a plataforma FreeBSD 8 ou 9 com
>>>>>> OpenBGPD, já
>>>>>> migrou para o FreeBSD 10?
>>>>>>     Se sim o processo ocorreu tudo tranquilo, se manteve a
>>>>>> performance e
>>>>>> estabilidade?
>>>>> Oi Jeferson,
>>>>>
>>>>> Tudo tranquilo. Nosso router de borda era um FreeBSD 9.2 com 
>>>>> OpenBGP e
>>>>> já tem uns meses que está rodando com 10-STABLE sem problemas.
>>>>> Na migração só cuidado com o openssh pois à partir de uma revision do
>>>>> STABLE o openssh passou à ser compilado com sandbox como default na
>>>>> separação de privilégios e aí é necessário capsicum habilitado no
>>>>> kernel. O GENERIC já vem com capsicum habilitado. Eu digo cuidado 
>>>>> caso
>>>>> seu acesso ao router seja por ssh.  :)
>>>>>
>>>>> 20140303:
>>>>>           OpenSSH will now ignore errors caused by kernel lacking
>>>>> of Capsicum
>>>>>           capability mode support.  Please note that enabling the
>>>>> feature in
>>>>>           kernel is still highly recommended.
>>>>>
>>>>> 20140227:
>>>>>           OpenSSH is now built with sandbox support, and will use
>>>>> sandbox as
>>>>>           the default privilege separation method.  This requires
>>>>> Capsicum
>>>>>           capability mode support in kernel.
>>>>>
>>>>> Do mais tudo tranquilo e funcionando perfeitamente.
>>>>>
>>>>> []'s
>>>>> Gondim
>>>>> -- 



More information about the gter mailing list