[GTER] Roteador no seu limite de uso?

Gustavo Santos gustkiller em gmail.com
Quarta Janeiro 21 18:24:27 BRST 2009


Bruno,

Eu fiz aqui o seguinte, ( procurando uma forma de gerar as listas
automaticamente).. mas enfim, segue como eu fiz.

Utilizando a consulta de AS do site www.robtex.com (muito bom..)   peguei
todos os prefixos anunciados pelo AS15169  "google"  criei uma address list
com os blocos do google, criei regras de mangle ( prerouting e postrouting)
para marcar pacotes originados dos ips da addresslist com nome
as15169google, marquei os pacotes de entrada como google_in  e saida como
google_out.

Ai é so utilizar queue tree escolhendo as interfaces de entrada e de saida
escolhendo os pacotes marcados devidamente e pronto, você vai ver o trafego
do as 15169 em tempo real.. isto esta ajudando, apos conseguir um top 10 dos
as que mas acessamos para definir o melhor PTT a se conectar em sampa. ( com
tempo, o que esta dificil no momento) pretendo automatizar a criação destas
regras e address lists. Mas para nossa necessidade esta funcionando muito
bem.

Para facilitar, segue regras utilizadas em anexo.
1-Pesquisar os prefixos do AS desejado ( no caso 15169)
2- Criação da address list.
---------------------------------------------------------------------------------------
add address=64.15.112.0/20 comment="" disabled=no list=google
add address=208.65.152.0/22 comment="" disabled=no list=google
add address=208.117.224.0/19 comment="" disabled=no list=google
add address=64.233.160.0/19 comment="" disabled=no list=google
add address=66.102.0.0/20 comment="" disabled=no list=google
add address=66.249.64.0/19 comment="" disabled=no list=google
add address=72.14.192.0/18 comment="" disabled=no list=google
add address=74.125.0.0/16 comment="" disabled=no list=google
add address=89.207.224.0/24 comment="" disabled=no list=google
add address=193.142.125.0/24 comment="" disabled=no list=google
add address=194.110.194.0/24 comment="" disabled=no list=google
add address=209.85.128.0/17 comment="" disabled=no list=google
add address=216.239.32.0/19 comment="" disabled=no list=google
---------------------------------------------------------------------------------------

2-Marcação de pacotes do AS
----------------------------------------------------------------------------------------
PS: exemplo se você estiver utilizando o Mikrotik como bridge
/ip fire mangle
add action=mark-packet chain=prerouting comment="as15169 google"
disabled=yes in-bridge-port=in new-packet-mark=google_in passthrough=no \
    src-address-list=google
add action=mark-packet chain=postrouting comment="" disabled=yes
dst-address-list=google new-packet-mark=google_out out-bridge-port=in
passthrough=no
PS: para utilizar em modo router, substitua o in-bridge-port e out
bridge-port para in-interface e out-interface  a interface que esta
conectada diretamente com seu upstream provider.
---------------------------------------------------------------------------------------
3- Criação do Queue Tree ( para vizualização do trafego , priorização ,
shape.
/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no
name="as15169_google_dl" packet-mark=google_in \
    parent=global-in priority=1 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no
name="as15169_google_ul" packet-mark=google_out \
    parent=global-out priority=1 queue=default

Pronto. :)




2009/1/21 bruno em Openline.com.br <bruno em openline.com.br>

>
> Ola
>
> --- Gustavo Santos <gustkiller em gmail.com> escreveu:
> > Estou bastante curioso com a RB1000, mas perambulando pelo forum oficial,
> > com com a grana da  RB1000 aqui no brasil, você compra um servidor pronto
> > Xeon
>
> Eu fiz a mesma colocacão na época da escolha do hardware, mas me
> foi colocado que havia restricões de energia no local e a RB1000
> consome muito, mas muito menos que qualquer PC.
>
> > e o interessante que com algumas artimanhas da pra ver
> > o trafego e controlar a banda por AS em tempo real sem netflow.
> > ( da um trabalho considerável, mas o resultado final vale a pena,
>
> Conta conta ;-)
>
> > um exemplo que fiz nos ultimos dias foi para ver o trafego do nosso
> > AS para o AS do google).
>
> []s, !3runo Cabral
>
> --
> gter list    https://eng.registro.br/mailman/listinfo/gter
>



More information about the gter mailing list