[MASOCH-L] FREENAS x CIFS x DEBIAN

CV Marcelo Guido - IFI marceloguidomgog at fab.mil.br
Thu Aug 24 11:33:44 BRT 2017


Prezado Douglas, desculpe a demora em responder. Acabaram surgindo 
outras "urgências" e este problema teve de esperar.

Meu cenário é o seguinte:

AD - Windows 2K12
Servidor de arquivo - FREENAS 9.10
Clientes - Windows - OK
             - Linux Não OK

Ao verificar os logs do freenas observo que as máquinas windows, quando 
mapeiam o drive via script de logon, passam a dupla DOMINIO\USUARIO para 
o FREENAS, já as máquinas linux passam apenas o USUARIO, desta forma o 
freenas ao consultar o AD não consegue autenticar, e retorna a mensagem 
de NT_STATUS_ACESS_DENEID. A mensagem que obtenho no auth.log do linux é 
de permissão negada, o que faz todo o sentido.

Assim como no Windows, existe script logon para os usuários linux, de 
forma que possam mapear o drive que se encontra no FREENAS e outros 
drives que estão em um file server Windows. O mapeamento linux está 
sendo feito via PAM MOUNT (pam_mount_conf.xml).

Alguma ideia de como avançar na solução do problema?

Abraços!
Marcelo Guido

Em 07-08-2017 10:18, Douglas Fischer escreveu:
> ​Existe algum erro de usuário(ou sintaxe de usuário) e/ou senha ​na sua
> execução via bash.
>   - Está usando usuário at domínio ou domínio\usuário?
>   - Lembrou de escapar o "\" -> domínio\\usuário ?
>
>
> Olhou nos logs do FreeNAS?
>
> Em 7 de agosto de 2017 08:12, CV Marcelo Guido - IFI <
> marceloguidomgog at fab.mil.br> escreveu:
>
>> Prezados, bom dia!
>>
>> Estou com um compartilhamento CIFS, criado em um FREENAS que não consigo
>> mapear de modo nenhum no Linux, mas apenas via linha de comando.
>> Explico: Na interface gráfica do Gnome, quando escolho a opção LOCAIS e
>> clico em CONECTAR AO SERVIDOR, configuro os dados do Servidor (IP),
>> compartilhamento (CIFS_DO_FREENAS$), nome do domínio (MEU_DOMINIO),
>> usuário(MEU_USUARIO_DOMINIO) e senha (SENHA), clico em conectar e
>> consigo acesso ao referido compartilhamento. Quando tento fazer via
>> linha de comando, seja usando o pam_mount.conf.xml (que é montado no
>> script de logon do usuário na rede) ou mesmo via linha de comando (sudo
>> mount -t cifs //SERVER/COMPARTILHAMENTO$
>> /home/DOMINIO/USUARIO/.NetworkFolders/MARCADOR -o nodev,nosuid), não
>> consigo obter sucesso.
>>
>> Olhando o auth.log, o que tenho de resposta é: mount error(13):
>> Permission denied
>>
>> O mais interessante é que, quando faço o mesmo, em máquinas windows (a
>> maioria dos clientes da rede), consigo mapear sem maiores problemas.
>>
>> Alguma sugestão do que pode estar errado?
>>
>> Abraços!
>>
>> Marcelo Guido
>> --------------------------------------------------
>> [PT] Texto confidencial para uso exclusivo do destinat�rio. N�o o divulgue
>> e apague-o imediatamente se o recebeu por engano.
>> [EN] <i>This is a confidential text to be exclusively used by the
>> recipient. Do not disclose it to anybody and delete it immediately if you
>> received it by mistake.
>> [ES] <i>Texto confidencial para uso exclusivo del destinatario. Si usted
>> lo recibi� por error no lo divulgue y excl�yalo inmediatamente.
>>
>> __
>> masoch-l list
>> https://eng.registro.br/mailman/listinfo/masoch-l
>>
>
>


--------------------------------------------------

[PT] Texto confidencial para uso exclusivo do destinat�rio. N�o o divulgue e apague-o imediatamente se o recebeu por engano.

[EN] <i>This is a confidential text to be exclusively used by the recipient. Do not disclose it to anybody and delete it immediately if you received it by mistake.

[ES] <i>Texto confidencial para uso exclusivo del destinatario. Si usted lo recibi� por error no lo divulgue y excl�yalo inmediatamente.




More information about the masoch-l mailing list