[GTER] Proxy ARP + iproute2

Igor Luiz Oliveira de Souza igorluizosouza em gmail.com
Quinta Janeiro 22 00:12:10 BRST 2009


Olá pessoal,

Sou novato na lista, gostaria de começar dando um olá a todos e espero 
poder trazer boas contribuições.

Pra começar, estou precisando de um help... ;-)
Estou me batendo com o seguinte problema:
Tenho um servidor PPPoE, com proxy_arp funcionando perfeitamente. 
Adicionei uma terceira interface, sendo que agora este servidor é 
provido de dois Links(Telemar+Embratel). Com a inserção do link 
Embratel, o gateway default passa a ser  Embratel, porém tenho alguns 
IP's reais da Telemar atribuídos aos clientes PPPoE.
Neste status, eth0=IP_Telemar, eth1=IP_Embratel, eth2=Servindo clientes 
PPP,  gateway default Embratel, o proxy_arp para os IP's reais da 
Telemar, continua funcionando perfeitamente. Porém ao criar um regra 
para roteamento por origem para esse pool de IP's reais da Telemar 
saírem pelo meu gateway Telemar, o proxy_arp deixa de funcionar. Tenho 
outra máquina Telemar no barramento, pingando para o IP real Telemar do 
cliente PPPoE, e no exato momento que faço o "ip rule add from XXXXXX 
table telemar", o proxy_arp pára. É só fazer um "ip rule del...." e a 
comunicação volta a funcionar.

Acredito que pode ser algo bem bobo, mas não consegui me achar.... 
Alguém pode dar alguma luz?

Grato desde já.

-- 
Igor Luiz Oliveira de Souza
Solic Tecnologia e Sistemas
+55 (71) 9127-7678
igorluiz em solic.com.br




More information about the gter mailing list